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Hello there...
Thank you for purchasing my theme. If you have any questions that are beyond the scope of this help file, please feel free to contact me via Support page. Thanks so much!
By: Vergo & Themnific | Support*
* Please note, that theme support does not include:
· Customization and installation services
· Support for third party software and plug-ins
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3. Default Setup
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· Elementor: Full Width Column (for Slider)
· Elementor: Columns
· Blog/News Template
5. Styling (Admin panel)
6. Custom Templates (Posts, Pages)
7. Post Settigns
8. Custom Widgets
9. Images
10. Custom Menu
11. Plugins
12. Demo Import (XML file)
13. Translation
 
Theme Instalation
Installation via WP Dashboard:
1. Unzip/extract the main (downloaded) theme package – to get codate.zip file,
2. Go to Appearance >Themes,
3. click on “Add New” > and “Upload theme”,
4. click on ‘Browse’ button, find codate.zip file on your computer and press 'Install Now',
5. Activate theme,
6. Go to Appearance > Install Plugins after theme activation and install and activate Redux Framework plugin!
7. Refresh page and 'Codate - admin panel' button will appear;
8. Go to Codate - admin panel (theme options) and setup theme.
 
Installation via FTP:
1. Unzip/extract the main (downloaded) theme package / twice / to get theme folder ‘codate’,
2. Using FTP client (e.g. Filezilla) upload 'codate' folder into 'themes' folder in your WordPress installation ( YOUR_HOSTING_ROOT/YOUR_SUBDIRECTORY/wp-content/themes/ ),
3. Go to Appearance >Themes, find Codate theme and activate theme,
4. Go to Appearance > Install Plugins after theme activation and install and activate Redux Framework plugin!
5. Refresh page and 'Codate - admin panel' button will appear;
6. Go to Codate - admin panel (theme options) and setup theme.
 
You have to install and activate required plugins (Redux, Elementor and Codate Addons). You can do this by visiting Appearance » Install Plugins inside wp dashboard.
Required Plugins
The following message may be visible after theme activation:
[image: img]
Go to Appearance » Install Plugins and install and activate following plugins:
1. Redux Framework
2. Elementor: after activation go to Elementor > Settings and make basic setup of the plugin:
[image: https://nofussworks.com/docs/codate/images/required-01.png] Save changes and that's it. You can edit any page in the page builder later.
3. Codate Addons
Default Setup
1. After theme activation go to Appearance > Install Plugins, and install and activate Redux Framework plugin!
2. Then go to Codate - admin panel
[image: img]
and hit "Save Changes" button to set default style settings:
[image: img]
You can change styling options later.
 
2. Following (or similar) message may be visible after theme activation:
[image: img]
Click on 'Begin activating plugins' link and install and activate 'Redux Framework' (if not installed yet), Elementor and 'Codate Addons' plugins. Or you can do this by visiting Appearance » Install Plugins
 
4. IMPORTANT! It is possible that after theme activation are images wrongly cropped and look ugly! In this case use the following plugin: http://wordpress.org/extend/plugins/regenerate-thumbnails/ to regenerate old thumbnails (from previous theme).
Start regeneration in Tools > Regen. Thumbnails after plugin installation. This process can take a while and you cannot close tab/window until regeneration is done.
 
 
 
Homepage Setup
1. In 'Pages' section create new page > name it 'Home'
2. Select 'Elementor Full Width' template for this page and save the page:
[image: img]
3. Go to Settings > Reading and created 'Home' page set as Static page > Front page,
[image: img]
4. The empty homepage is created now! In next steps, we'll create homepage content using 'Elementor' page builder.
 
 
Elementor
Important!
I recommend creating few classic blog posts before you start creating templates in Elementor. Set 'featured images' for all your posts.
1. Go to Pages section and edit 'Home' page, which we have created in previous steps:
[image: img]
2. Make sure that 'Elementor Full Width' template is selected for this page (a.), then hit 'Edit with Elementor' button (b.):
[image: img]
Full-Width Column - Adding Slider or Carousel
1. Make sure that Codate Addons plugin is installed.
2. In 'Elementor edit mode' hit on 'Add new section' button and add select 'one column' section:
[image: img]
[image: img]
3. Hover over the section and click on 2nd blue icon to edit section (a.) In left section select 'Full Width' and 'No Gap' options (b.)
[image: img]
4. Then just click + sign and drag 'Themnific: Main Slider' (or 'Themnific: Carousel') block into section.
[image: img]
5. And that's it! Edit widget options and 'Slider placeholder' will appear after the saving; on live homepage will be displayed fully functional slider.
[image: img]
One 'Boxed' Column
1. In 'Elementor edit mode' hit on 'Add new section' button and add select 'one column' section:
[image: img]
[image: img]
2. Hover over the section and click on 2nd blue icon to edit section (a.) In left section select 'Boxed' width with 1360px and 'Wider' gap option (b.)
[image: img]
3. Then just click + sign and drag e.g. 'Themnific: Magazine (Classic)' block into section.
[image: img]
4. Adjust widget options (title, number of posts or featured category) and save page.
5. Suitable blocks for 'boxed' single column are Themnific: Magazine (Classic), Themnific: Magazine (Grid),Themnific: Magazine (Plain Posts)
Adding Columns
1. In 'Elementor edit mode' hit on 'Add new section' button and select 'two columns' section:
[image: img]
[image: img]
2. Using Drag&Drop resize columns to e.g. 68% (for wide column) and 32% (for narrow column):
[image: img]
3. Select Wider in the 'Columns Gap' option and 1360px boxed width.
4. Click on the + sign in wide column and then drag blocks from the left menu; e.g. add 'Themnific: Blog ' block to this wide column:
[image: img]
5. Adjust 'Number of posts' parameter and optionally select 'featured category' in left panel.
6. Click on the + sign in narrow column, then drag Sidebar block from the left menu into it.
[image: img]
7. Choose 'Sidebar' section which you can setup in Appearance > Widgets
[image: img]
Adding Hero image
 
1. Add new section and add two column layout:
[image: img]
[image: img]
2. Hover over the section and click on 2nd blue icon to edit section:
[image: img]
3. Switch to the Style tab (a.) and add background image (b.)
[image: img]
[image: img]
4. Then just click on + sign in the left column and drag; e.g. Heading block into it.
[image: img].
5. Click on heading; and in Content / Style / Advanced tabs customize the appearance (size, text colors, font style, padding etc.).
[image: img]
[image: img]
6. After all these, adjust overall padding (spacing) of the 'hero' section.
a. edit section ,
b. switch to the Advanced tab,
c. adjust top and bottom padding of the section.
[image: img]
 
 
Blog Template
1. If you want to create News (or Blog) page, create an empty page (Default template),
2. name it News (or Blog),
3. go to Settings > Reading and set this page as 'Post page',
4. adjust a number of posts.
[image: img]
 
 
Theme Setup - Admin panel
[image: img]
Theme comes with extensive options panel with functions divided to these sections:
[image: img]
General Settings:
1. Upload your Main logo image,
2. Select 'Container Width Limitation',
3. Choose blog layout for blog page and archives,
4. Enable/disable 'Uppercase' fonts,
5. Enable/disable 'Additional Letter Space'.
[image: img]
 
Primary styling:
1. Select font family (with color, style and width) for main body text,
2. Choose colors for typographic elements: body, wrapper, containers (ghost color), text/links, hover, borders etc.
[image: img]
 
Header Styling & Settings:
1. Select type of the header,
2. Setup color scheme (background, font, links and border colors) for header,
3. Set other colors for header elements (sub-menus etc.),
4. Setup logo + "fallback color scheme" for 'Transparent Header' here,
5. Set custom margins and width limitation for logo image.
[image: img]
 
Footer Styling:
1. Setup the footer logo and footer text.
2. Select color scheme for footer (footer background, text, links, hover, borders etc.)
[image: img]
 
Other Styling:
1. Set font styling for 'Meta' sections (date, category etc. post information)
2. Choose background color for elements (buttons, lines etc.),
3. Select text/link color for elements (buttons, lines etc.),
4. Set color scheme for image backgrounds.
[image: img]
 
 
Headings Typography:
1. Select Font-family for all headings (h1- h6) and 'post titles',
2. Select font weight for all headings (h1- h6) and 'post titles',
3. Select Font-size for all headings (h1- h6) and 'post titles',
4. Select font color for all headings (h1- h6) and 'post titles',
[image: img]
 
Post Settings:
1. Turn On/Off partial post sections.
[image: img]
Social Networks Settings:
1. Enable "Social Networks" section,
2. Enter the full URL of social network, your profile or account (enter full URL: http:// or https:// including).
[image: img]
 
 
If you are finished click on "Save changes" button!
 
 
Custom Templates (for Posts and Pages)
 
1. Create a page or a post.
2. In Page Attributes (Post Attributes) section select custom template: 'No Sidebar Layout' or 'Right Sidebar Layout' for pages and Single (with Hero Image) for posts.
3. Click the Publish button to publish your page/post.
 
Post Settings
In post add/edit post screen, below the post content is located custom 'Themnific Post Options' tab:
[image: doc]
a) You can select the position of the sidebar on the single post,
b) Enable / Disable featured image on the single post (for 'Classic Image' only).
 
 
Custom Widgets
Go to Appearance > Widgets and setup your sidebar and footer widget areas. Widgets are very easy to setup.
Following widgets are used in theme demo:
[image: img]
In theme demo may be used custom widgets which come with 3dr party plugins (Top 10 plugin, Newsletter etc.).
Please see 'Plugins' chapter for more info about these plugins.
 
 
Images
IMPORTANT! It is possible that after theme activation are images wrongly cropped and look ugly!
In this case use this plugin: http://wordpress.org/extend/plugins/regenerate-thumbnails/ to regenerate old thumbnails from previous theme.
After plugin installation start regeneration in Tools > Regen. Thumbnails This process can take a while and you cannot close tab/window until regeneration is done.
Images and thumbnails are generated automatically.
To display thumbnails correctly upload images via WP interface using "Set featured image" button.
After image upload set featured image.
 
Featured Images - Minimal Sizes
1. Main Slider section + single post (Hero Image):1920x1000px;
2. Magazine widgets : 550x350px;
3. Magazine widgets (verticaly croped images): 500x800px;
4. Single post (Classic Image): 852x500px.
 
 
Custom Menu :
 
! Create your own custom menus first! Please see the following tutorial!
 
Colored Menu Item (on the right)
1. Toggle 'Screen Options' on the top of the menu screen:
[image: https://nofussworks.com/docs/codate/images/custom-menu-03a.png]
2. Enable 'CSS Classes' option:
[image: https://nofussworks.com/docs/codate/images/custom-menu-03b.png]
3. Toggle any menu item and type special word into 'CSS Classes' field
[image: https://nofussworks.com/docs/codate/images/custom-menu-03c.png]

 
Menu Icons
 
1. Before (or after) menu label add this piece of code
<i class="fas XXX"></i>
Enter full icon code - 'fa' class is required.
[image: https://nofussworks.com/docs/codate/images/custom-menu-02.png]
2. For XXX you can set any icon name. You can find all icon names on Font Awesome homepage.
3. You can see how-to video here. It is not tutorial for my theme but the process is the same.
 
Plugins
 
Elementor
Elementor plugin will help you create awesome layouts for your pages.
Go to Appearance » Install Plugins inside wp dashboard and install and activate Elementor plugin.
The basic setup of this plugin is very easy; go to Elementor > Settings and disable default color and fonts:
[image: https://nofussworks.com/docs/codate/images/plug-10.png]
Save changes and that's it. You can edit any page in the page builder now.
 
 
 
MailChimp for WordPress
You can easily create a newsletter subscribe form with 'MailChimp for WordPress' Plugin: Plugin Homepage
Into search field (in Plugins > Add New) paste MailChimp for WordPress and Install this plugin
The plugin can be set in MailChimp for WP section:
[image: https://nofussworks.com/docs/codate/images/mb-plug-01.png]
In demo is used subscribe form with the following markup: https://pastebin.com/rQ7h7h4z
 
Top 10 – Popular posts plugin for WordPress
Into search field (in Plugins > Add New) paste 'Top 10 – Popular posts plugin for WordPress' and Install and activate this plugin.
After plugin activation setup 'Popular Posts [Top 10]' widget in Appearance > Widgets with following, highlighted options:
[image: https://nofussworks.com/docs/codate/images/plug-04.png]
 
 
Recent Tweets Widget
The theme is compatible with Recent Tweets Widget plugin.
In search field (Plugins > Add New) insert 'Recent Tweets Widget' and Install plugin.
Plugin widget can be set in Appearance > Widgets:
Note!: You need to get "consumer and secret" codes for Recent Tweets Widget:
1. Go to https://dev.twitter.com/apps/new and log in, if necessary
2. Enter your Application Name, Description and your website address. You can leave the callback URL empty.
3. Accept the TOS, and solve the CAPTCHA.
4. Submit the form by clicking the Create your Twitter Application
5. Copy the consumer key (API key) and consumer secret from the screen into widget fields
 
 
Social Pug
Plugin page: Plugin Homepage
Into search field (in Plugins > Add New) insert 'Social Pug' and Install this plugin.
Plugin can be set in dashboard > Social Pug:
[image: https://nofussworks.com/docs/codate/images/plug-02.png]
Theme is compatible with AddToAny Share Buttons too.
 
 
Contact Form 7
Plugin page: Plugin Homepage
Into search field (in Plugins > Add New) insert 'Contact Form 7' and Install this plugin
You can create own contact form(s) in the main wp menu > Contact.
You can display created 'contact form' on any page using ashortcode.
On demo page is used contact form with the following markup: https://pastebin.com/a0Hcywkd
Please read plugin documentation for more info about this very flexible plugin.
 
Other Recommended Plugins
 
Autoptimize →
Smush →
FitVids for WordPress →
WP Featherlight →
WP Sticky Sidebar →
 
 
 
 
Demo Import (XML file)
 
Make sure that Codate theme, Elementor and Codate Addons plugins are installed and activated before demo import.
One Click Demo Import
Install and activate ' One Click Demo Import' plugin.
After that import full demo content easily in Appearance > Import Demo Data.
[image: img]
Just hit 'Import Demo Data' and wait until import is done.
 
 
 
Elementor templates
If you don't want to import whole demo content you can import just elementor templates (e.g. layout of the homepage) using .json file.
.json files are located in the main theme package, in 'spec' folder. Extract .json files to your computer.
[image: img]
Extract .json files to you computer.
Import template when you are editing any page in Elementor - > click on 'Add Template' button > Import Template:
[image: img]
Find .json file on your computer and import Elementor template.
 
 
Important!
Due licenses all imported images are for testing purposes only and cannot be used on your live website!!!
You can download free photos for your commercial & personal works on sites like:
http://picjumbo.com/
http://pixabay.com/
https://unsplash.com/grid
 
Translation
This theme is translation/localization ready and comes with codate.pot file. File is located in ../codate/lang/ folder.
1. You need to use localized WordPress installation (core) in the first place:
[image: img]
If not, localization will be not successful.
2. .pot file is located in root theme folder inside 'lang' sub-folder: ../codate/lang/
3. Download poedit software here,
4. Install software it and translate codate.pot file (line by line),
5. Once you have translated all the strings, you can save this as your .po file.
The filename of your .po / .mo file is crucial! Gettext uses the ISO 639 standard for language abbreviations and ISO 3166 for locales. If your translation is written in Deutsch for example, your file name will look like de_DE.po. Capitalization is also important here. For a full list of language and country codes, check out these two links:
· Gettext language codes
· Gettext country codes
Once you save, POEdit by default automatically creates a .mo file alongside your .po file. Put these files into 'lang' folder.
6. Access your wp-config.php file found in your WordPress' root folder. Your file should already contain define('WPLANG', ''); but if it does not, you can add it in. You simply need to add your language and locale code into the define. If you were to translate your theme into German, you would have this:
define('WPLANG', 'de_DE');
Your internationalization is complete!
 
 
 
 

Once again, thank you so much for purchasing this theme.
Go To Table of Contents
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